Error logging bug causing bots to crash

Incident Report for Java Lava bot status

Resolved

All bots have had the new bug patch for error logging sent out, I am sorry for the quality of these updates lately, I just gotten back home from a much needed vacation so I am a little slow with getting bug patches out right this second but I am glad that I gotten it all fixed.
Posted Aug 17, 2025 - 11:02 EDT

Monitoring

The lead developer of Java Lava, PhillsPhanbh3 is outputting the fix now for the TypeError: LogError is not a function" to make sure all errors get logged to our error logging system at this time, one of our major files had a small issue but it was fixed, thankfully. I'll let yall know when the incident is resolved!
Posted Aug 17, 2025 - 10:17 EDT

Identified

The lead developer of Java Lava PhillsPhanbh3 has identified the issue, it is a "TypeError: LogError is not a function" issue so I am going to be working on a fix at this time!
Posted Aug 17, 2025 - 10:06 EDT

Investigating

The Java Lava developers is currently aware of some issues with our error logging system, we are currently looking for the underlying issue at this time and will update when we identified the underlying issue and will get a fix out!
Posted Aug 17, 2025 - 09:58 EDT
This incident affected: Java Lava bot and Vip custom branded bots (HMO, MiniMoch, Shadowbot, Tenkay, ๐•๐ข๐ฅ๐ญ๐ซ๐ฎ๐ฆ๐ข๐ญ๐ž ๐„๐ฆ๐ฉ๐ข๐ซ๐ž, The inked dream bot, Aurelian).