The Java Lava website is now loading quickly. resolved.
Posted Oct 04, 2025 - 10:06 EDT
Identified
Issue was identified, now we are getting reports of it being slow but loading in, looking into why it is loading slow at this time.
Posted Oct 04, 2025 - 09:51 EDT
Investigating
We are currently receiving reports that the Java Lava Website is not loading properly, and we are investigating the root cause and working on a fix for this issue. We will give out more info when we can.